Back to overview
Degraded
Intermittent slowness in US region
Feb 22 at 12:45pm IST
Affected services
Kissflow - US
Resolved
Feb 22 at 02:15pm IST
The incident has been resolved. The system got back to the normal state and we are investing on the root cause and we are continuously monitoring the system for its performance.
Affected services
Kissflow - US
Created
Feb 22 at 12:45pm IST
Kissflow is experiencing intermittent slowness for multiple customers in the US region. Our team is actively working to resolve the issue and restore normal performance. We apologize for any inconvenience this may cause. Thank you for your patience.
Affected services
Kissflow - US