Back to overview
Degraded

Global Service Disruption Due to Cloudflare DNS Outage

Nov 18 at 07:12pm IST
Affected services
Kissflow - EU

Resolved
Nov 18 at 11:22pm IST

The issue has been resolved by the Cloudflare team, and they have confirmed that all services are now operating normally across the region.

Updated
Nov 18 at 08:31pm IST

Status: Recovering

Cloudflare has confirmed that a fix has been implemented and services are now back to normal. They are continuing to monitor for any residual errors.
All affected services should now be operational.

Ref: https://www.cloudflarestatus.com/

Created
Nov 18 at 07:12pm IST

There is a global intermittent outage with Cloudflare, our DNS provider, which is causing service unavailability. Currently, our services are unavailable in EU regions, and according to Cloudflare's latest status update, the issue may spread to other regions as well.