The Kissflow.eu site is currently unreachable.
Resolved
Nov 06 at 02:15pm IST
The issue has been successfully resolved. The application is now fully operational in the EU region.
Please note that DNS propagation may take some time, depending on the DNS servers of some customers. The domain will gradually propagate across all DNS servers.
Status : Resolved
Affected services
Kissflow - EU
Updated
Nov 06 at 02:06pm IST
The DNS lookup failure issue is now in the process of being resolved. It’s gradually reflecting, though it may take some time. The team will provide an update once it’s fully resolved.
Status : Verification & Validation
Affected services
Kissflow - EU
Created
Nov 06 at 01:15pm IST
The kissflow.eu site is currently unreachable due to a DNS lookup failure.
The Kissflow team is actively working on the issue
Status: On going
Affected services
Kissflow - EU