Get in touch
Back
Degraded

Intermittent slowness

Started 13 Nov at 12:15pm IST, resolved 15 Nov at 07:00pm IST.

Kissflow - US
Resolved

We're happy to announce that the intermittent delays with Kissflow application access have been resolved. Thank you for your patience. You can now use Kissflow without any disruptions.

Posted 15 Nov at 07:00pm IST.
Created

Notice:
We are currently experiencing intermittent delays when accessing the Kissflow application. Please be aware that our team is diligently investigating this issue and working towards a resolution. We will keep you informed with regular updates as we gather more information. Your understanding and patience during this period are greatly appreciated. Thank you for your continued support.

Posted 13 Nov at 12:15pm IST.