Get in touch
Back
Degraded

Some of the services are unavailable.

Started 25 May at 06:40pm IST, resolved 25 May at 07:15pm IST.

Resolved

We've successfully addressed a performance issue impacting request latency on our CloudFlare-integrated services. The surge in hits per minute was traced back to an optimization of code, causing CPU spikes and queuing. After upgrading the MongoDB tier to M140, normalcy was restored by 7:15 PM. A code fix was implemented , followed by a MongoDB cluster tier downgrade to M80. We appreciate your patience.

Posted 25 May at 07:15pm IST.
Created

Kissflow experienced service disruptions due to a bulk write operation by a specific customer's integration. The number of API requests has been shot up due to this. Our team is actively addressing the issue to restore services swiftly. Thank you for your patience and understanding.

Posted 25 May at 06:40pm IST.