Get in touch
Back
Degraded

Intermittent availability issues

Started 21 Feb at 11:00am IST, resolved 21 Feb at 11:30am IST.

Resolved

Slowness is resolved. This is because there is a high load in a specific DB shard due to Process Admin search. System is now optimized by scaling the database cluster for smoother performance. Thank you for your patience! We are continuously monitoring for the anomalies.

Posted 21 Feb at 11:30am IST.
Created

Kissflow is experiencing intermittent slowness for multiple customers. Our team is actively working to resolve the issue and restore normal performance. We apologize for any inconvenience this may cause. Thank you for your patience.

Posted 21 Feb at 11:00am IST.