Wednesday 22nd July 2020

Kissflow Process Module Kissflow is slow and inconsistent

[Resolved] The issue is fixed as of Wednesday, 2020-07-22 07:00 UTC. We are investigating the root cause.

[Update] Kissflow is very slow and few modules are not working, beginning at Wednesday, 2020-07-22 06:45 UTC. We are investigating the issue.