Wednesday 13th March 2019

KiSSFLOW Login Services KiSSFLOW is not accessible.

KiSSFLOW is not accessible and we are facing issues with our service provider. We are following up with them and monitoring progress.

[Update][04/13/2019 5:15 AM] The issue is still not resolved. KiSSFLOW is hosted in Google Cloud and it is facing an unexpected outage for the past 2 hours. We are continuously monitoring the developments.

[Update][04/13/2019 6:40 AM] The issue is completely resolved. We are expecting a detailed report from our service provider and will share the findings.