Friday 16th February 2018

KiSSFLOW Apps KiSSFLOW is not accesible.

[Resolved] There was a minor outage with our service provider(Google Cloud) for around 10 minutes. Now the services are back to normal and we are actively monitoring the systems as well. We regret the inconvenience caused.

[Investigating] KiSSFLOW is not accessible and we are investigating the cause right now.