Thursday 1st February 2018

KiSSFLOW Apps KiSSFLOW is not accesible.

[Resolved] There was a major outage in Google Cloud for almost an hour. All our applications are hosted in Google Cloud and the customers were not able to use KiSSFLOW from 6:30 AM PST to 7:30 AM PST. Now the services are back to normal and we are actively monitoring the systems as well. We regret the inconvenience caused.

[Investigating] KiSSFLOW is not accessible and we are investigating the cause right now.