Back to overview
Downtime

Kissflow site is currently unreachable

Jun 12 at 11:30pm IST
Affected services
Kissflow - US
Kissflow - EU
Kissflow - APAC

Resolved
Jun 13 at 03:49am IST

Status : Resolved .

Most of the Google Cloud products are fully recovered.
Our system got back to the normal state and issue has been resolved .

Status Page of Google Cloud: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Updated
Jun 13 at 01:08am IST

Status: Recovery is in progress

Google Cloud Platform has reported that all regions except US have fully recovered. The US region, which hosts many of Kissflow's core services, is mostly recovered, but there is no ETA for full restoration yet from GCP.

You can follow the official GCP incident update here:
https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

Google will provide their next update by Thursday, June 12, 2025, 13:00 PDT.

We are closely monitoring the situation and will continue to keep you informed.

Created
Jun 12 at 11:30pm IST

Incident: Kissflow site is Unreachable
Status: Investigating
Time Detected: 11.30 PM IST
We are currently experiencing an issue where accounts hosted in Kissflow.com is unreachable. Our team is actively investigating the root cause.This is due to Google Cloud Platform outage.

Google Status Page: https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

We will keep you posted .